Sublime Text Bedienung

Version 3126

Programm unter Applikationen: Sublime Text.app
Verzeichnis der Einstellungen: /Users/macbook/Library/Application/Support/Sublime Text 3

Sublime Text Kurztasten

File

cmd n neues File
cmd s Speichern
cmd shift S Speichern unter
cmd alt s Speichern alles
cmd o File öffnen
cmd w File schliessen
cmd shift n Neues Fenster
cmd shift w Fenster schliessen

Edit
cmd z Rückgängig –
cmd y Rückgängig +
cmd u Rückgängig bis zur letzten Eingabe
cmd c Kopieren
cmd v Einfügen
cmd ⏎ Einfügen leere Zeile unterhalb
cmd shift ⏎ Einfügen leere Zeile oberhalb
cmd x Ausschneiden
cmd shift v
cmd alt v
ctrl k Linie löschen bis zum Ende
ctrl shift k Linie löschen
cmd shift d Linie kopieren und einfügen auf der nächsten Zeile
cmd shift d Linie kopieren
cmd ⌫ Linie löschen bis zum Anfang
Cursor bewegen
cmd → Linienende
cmd ← Linienanfang
cmd ↑ Fileanfang
cmd ↓ File
ctrl g gehe zu Linie

cmd alt → File wechseln
End

Markieren (Selection)

cmd d+d     gleiche Wörter mehrfach markieren
cmd c           Linie markieren
Linie markieren Cursor bis Ende
Linie markieren Cursor bis Anfang
Bereich markieren
cmd F2         Bookmark setzen
cmd 12 F2  Bookmark löschen
F2                    Bookmark navigieren

Suchen / Ersetzen
cmd f Suchfenster
cmd g Finde nächstes Wort
cmd alt f Such- und Ersetzfenster
Diverses
x im Reiter Datei gespeichert
● im Reiter Datei nicht gespeichert

Textbausteine abrufen (Tools->Snippets)
Textbausteine anlegen (Tools->Developer->New Snippet)
z. B. TB1.sublime-snippet speichern im Verzeichnis unter

lorem ⌦ Blidtext

Sortieren
Block markieren und F5

Summe Wenn

Formel Ergebnis Variablen Beschreibung
Statistik
=ANZAHL(C4:C30) 16 3 Ermittelt die Anzahl der numerischen Werte in einem Bereich
=ANZAHL2(C4:C30) 21 1 Ermittelt die Anzahl der alfanumerischen Werte in einem Bereich
{=SUMME(WENN(C4:C30<=6;WENN(C4:C30>3,95;1;0)))} 8 4 Filtert Werte in einem bestimmten Bereich und zählt Sie, beide WENN-Funktionen müssen zutreffen UND-Verknüpfung  (Notenauswertung)
{=SUMME(WENN(C4:C30 <=6;1;0))} 22 4 Filtert Werte unter einem bestimmten Bereich und zählt Sie, Achtung leerzellen werden mitgezählt
{=SUMME(WENN(C4:C30 >4;1;0))} 8 6
=Heute() Freitag, 14. April 2017 6 Datum und Zeit
=JETZT()> 14.04.17 19:46 6 Tagesdatum und Zeit
3
3.96
2
2
2
2
3
4
4
e
e
e
r
e